Bug when connecting the USB cable

Post here to share useful tips and tricks, to ask questions about using your DM42 or to report software-related problems
Thomas_ER
Posts: 48
Joined: Mon Jul 24, 2017 1:19 pm
Location: Germany

Re: Bug when connecting the USB cable

Post by Thomas_ER » Mon Jun 25, 2018 10:42 am

There are 2 cases, and one from wawachief after the answer from Michael.
User wawachief wrote (among other details, he testet) "The problem seems to come from the DMCP part because I compiled the Hello world program." His story sends a new light to this error!
I could not find an answer to this case.
Before migrating to the new software/firmware model this behavior should be investigated.
[ HP48/49/50/42S/WP34/HP Prime/ DM42 (#00185+00318) ]

wawachief
Posts: 28
Joined: Tue Dec 12, 2017 6:39 pm
Location: France, Normandie

Re: Bug when connecting the USB cable

Post by wawachief » Mon Jun 25, 2018 11:39 am

You can upgrade to the new firmware. If you encounter the problem, you can downgrade back to 3.5. It won't brick your unit. That's what I did. Chances are you won't have any problem because it seems to be quite a rare phenomen. And I guess the more feedback SM gets, the faster the issue will be fixed.
DM42 SN:00218
HP-11c - HP-19b - HP25 - HP 45 - HP42s - HP48gx

StreakyCobra
Posts: 2
Joined: Thu Jun 14, 2018 8:09 am

Re: Bug when connecting the USB cable

Post by StreakyCobra » Thu Jun 28, 2018 10:02 pm

I sent back my unit last week and received a new working one. Michael told me they want to investigate, so let's see if they manage to find more information on this bug with my broken unit in hands.

wawachief
Posts: 28
Joined: Tue Dec 12, 2017 6:39 pm
Location: France, Normandie

Re: Bug when connecting the USB cable

Post by wawachief » Thu Jul 05, 2018 5:41 am

There is a new DMCP version 3.8 out there. I tried it full of hope, but I still got the same error when I plugged the USB cable, so the problem is not solved with this version :(
Back to 3.5 ...
DM42 SN:00218
HP-11c - HP-19b - HP25 - HP 45 - HP42s - HP48gx

wawachief
Posts: 28
Joined: Tue Dec 12, 2017 6:39 pm
Location: France, Normandie

Re: Bug when connecting the USB cable

Post by wawachief » Wed Aug 08, 2018 7:33 am

I tried to upgrade to DMCP_3.9. I still have the same issue when I plug the DM42 to USB power. I guess I'm still stuck to 3.5.
DM42 SN:00218
HP-11c - HP-19b - HP25 - HP 45 - HP42s - HP48gx

Post Reply