I failed in updating firmware V3.1

Post here to share useful tips and tricks, to ask questions about using your DM42 or to report software-related problems
Nobody
Posts: 10
Joined: Fri Nov 24, 2017 11:03 pm
Location: Tokyo

I failed in updating firmware V3.1

Post by Nobody » Sat Dec 23, 2017 5:01 am

I failed in updating DM42_qspi_3.1.bin.
My DM42 does not work now. What can I do with it?

1. At first, I updated DM42_flash_3.1.bin using dm_tool on Windows 10 with success.

2. Then I tried to update DM42_qspi_3.1.bin using dm_tool, before I realized that the update was not necessary.
I should not have tried that.

This update did not successfully finished.
Image

At the tine, my DM42 continues to show the following image, and I cannot exit that except "F" option.
Image

3. I tried updating DM42_flash_3.1.bin again.
Image

Then after exit from the previous image, an update for DM42_qspi_3.1.bin was asked.
The attempt for the update only brings me to the 2nd step.
Image
M.K.

25C, 29C, 67, 41CV, 41CX, 42S, 15C, 28S, 48SX, 48GX, Prime,
and DM42 SN:00176

dlachieze
Posts: 199
Joined: Thu May 04, 2017 10:20 am
Location: France

Re: I failed in updating firmware V3.1

Post by dlachieze » Sat Dec 23, 2017 9:53 am

Have you tried to flash the QSPI from the FAT disk as explained here ?
DM42: 00425 - DM41X: β00066

Nobody
Posts: 10
Joined: Fri Nov 24, 2017 11:03 pm
Location: Tokyo

Re: I failed in updating firmware V3.1

Post by Nobody » Sat Dec 23, 2017 10:02 am

dlachieze wrote:
Sat Dec 23, 2017 9:53 am
Have you tried to flash the QSPI from the FAT disk as explained here ?
Thanks, but I cannot access to its FAT now under this condition.
M.K.

25C, 29C, 67, 41CV, 41CX, 42S, 15C, 28S, 48SX, 48GX, Prime,
and DM42 SN:00176

User avatar
akaTB
Posts: 479
Joined: Tue May 02, 2017 11:56 am
Location: Milan, Italy

Re: I failed in updating firmware V3.1

Post by akaTB » Sat Dec 23, 2017 11:07 am

Been there, done that.
Greetings,
    Massimo
ajcaton
-+×÷ left is right and right is wrong :twisted: Casted in gold

Nobody
Posts: 10
Joined: Fri Nov 24, 2017 11:03 pm
Location: Tokyo

Re: I failed in updating firmware V3.1

Post by Nobody » Sat Dec 23, 2017 12:53 pm

I am again trying to flash the QSPI from the FAT disk, but no luck.

In the QSPI Load menu,
"4. Format FAT Disk" / "5. FAT Disk Media Test" both failed in ERROR:0a09.
"3. Activate USB Disk" seems to work, but "DM42_qspi_3.1.bin" file cannot be copied there.
M.K.

25C, 29C, 67, 41CV, 41CX, 42S, 15C, 28S, 48SX, 48GX, Prime,
and DM42 SN:00176

User avatar
akaTB
Posts: 479
Joined: Tue May 02, 2017 11:56 am
Location: Milan, Italy

Re: I failed in updating firmware V3.1

Post by akaTB » Sat Dec 23, 2017 1:18 pm

This seems an hardware error to me.
Greetings,
    Massimo
ajcaton
-+×÷ left is right and right is wrong :twisted: Casted in gold

User avatar
Walter
Posts: 1540
Joined: Tue May 02, 2017 9:13 am
Location: Close to FRA, Germany

Re: I failed in updating firmware V3.1

Post by Walter » Sat Dec 23, 2017 1:49 pm

Nobody wrote:
Sat Dec 23, 2017 12:53 pm
I am again trying to flash the QSPI from the FAT disk, but no luck.

In the QSPI Load menu,
"4. Format FAT Disk" / "5. FAT Disk Media Test" both failed in ERROR:0a09.
"3. Activate USB Disk" seems to work, but "DM42_qspi_3.1.bin" file cannot be copied there.
How do you know that "3. Activate USB Disk" seems to work?
DM42 SN: 00041 Beta
WP 43S running on this device

HP-35, HP-45, ..., HP-50, WP 34S, WP 31S, DM16L

Nobody
Posts: 10
Joined: Fri Nov 24, 2017 11:03 pm
Location: Tokyo

Re: I failed in updating firmware V3.1

Post by Nobody » Sat Dec 23, 2017 2:03 pm

Walter wrote:
Sat Dec 23, 2017 1:49 pm
Nobody wrote:
Sat Dec 23, 2017 12:53 pm
I am again trying to flash the QSPI from the FAT disk, but no luck.

In the QSPI Load menu,
"4. Format FAT Disk" / "5. FAT Disk Media Test" both failed in ERROR:0a09.
"3. Activate USB Disk" seems to work, but "DM42_qspi_3.1.bin" file cannot be copied there.
How do you know that "3. Activate USB Disk" seems to work?
After I select the option, I can see the drive from my PC.
M.K.

25C, 29C, 67, 41CV, 41CX, 42S, 15C, 28S, 48SX, 48GX, Prime,
and DM42 SN:00176

User avatar
Walter
Posts: 1540
Joined: Tue May 02, 2017 9:13 am
Location: Close to FRA, Germany

Re: I failed in updating firmware V3.1

Post by Walter » Sat Dec 23, 2017 2:31 pm

Nobody wrote:
Sat Dec 23, 2017 2:03 pm
Walter wrote:
Sat Dec 23, 2017 1:49 pm
Nobody wrote:
Sat Dec 23, 2017 12:53 pm
I am again trying to flash the QSPI from the FAT disk, but no luck.

In the QSPI Load menu,
"4. Format FAT Disk" / "5. FAT Disk Media Test" both failed in ERROR:0a09.
"3. Activate USB Disk" seems to work, but "DM42_qspi_3.1.bin" file cannot be copied there.
How do you know that "3. Activate USB Disk" seems to work?
After I select the option, I can see the drive from my PC.
OK, you see the drive. Do you see its directories as well? Do you see files therein? Can you copy files from there to your PC? Etc.
DM42 SN: 00041 Beta
WP 43S running on this device

HP-35, HP-45, ..., HP-50, WP 34S, WP 31S, DM16L

User avatar
akaTB
Posts: 479
Joined: Tue May 02, 2017 11:56 am
Location: Milan, Italy

Re: I failed in updating firmware V3.1

Post by akaTB » Sat Dec 23, 2017 2:42 pm

Walter wrote:
Sat Dec 23, 2017 2:31 pm
Nobody wrote:
Sat Dec 23, 2017 2:03 pm
Walter wrote:
Sat Dec 23, 2017 1:49 pm


How do you know that "3. Activate USB Disk" seems to work?
After I select the option, I can see the drive from my PC.
OK, you see the drive. Do you see its directories as well? Do you see files therein? Can you copy files from there to your PC? Etc.
He wrote he cannot copy qspi file therein.
Greetings,
    Massimo
ajcaton
-+×÷ left is right and right is wrong :twisted: Casted in gold

Post Reply