Editor bug using delete [VIDEO]

Please report issues with the DM41X Beta Firmware in this sub-forum
Post Reply
Boub65
Posts: 176
Joined: Tue Sep 12, 2017 4:34 pm
Location: Rabat, Morocco

Editor bug using delete [VIDEO]

Post by Boub65 »

Hi all,
This bug happened to me twice recently... when I wanted to replace an instruction in a program...

I am in the multi-line editor to replace an instruction
I insert a new instruction just after
I go up once (up arrow)
I hit delete (backspace arrow)
=> both instructions are deleted!

It happened when I did the "up" + "backspace" sequence...

It happened twice in few days, I suspected a problem with the backspace key, but no... it works just fine with no "double delete" when I edit X or Alpha register for example...

Sincerely,
Boubker.
Last edited by Boub65 on Sat Jul 17, 2021 2:32 pm, edited 3 times in total.
Sincèrement, Sincerely, 73,
Boubker

2xDM15L, DM41L, DM42 SN#00855 (+one lost during shipping), DM41X #00707
TI-89 titanium, CASIO fx-cg50 (to play with micropython)

There are three kinds of people in the world: those who know math and those who don't.
Boub65
Posts: 176
Joined: Tue Sep 12, 2017 4:34 pm
Location: Rabat, Morocco

Re: Editor bug using delete [VIDEO]

Post by Boub65 »

Here is the bug on video
https://youtu.be/RN5VbLlvv8s

(it's an unlisted video, you have to get throught the url to see it)

Seems to be repeatable replacing a LBL instruction!

Sincerely,
Boubker.
Sincèrement, Sincerely, 73,
Boubker

2xDM15L, DM41L, DM42 SN#00855 (+one lost during shipping), DM41X #00707
TI-89 titanium, CASIO fx-cg50 (to play with micropython)

There are three kinds of people in the world: those who know math and those who don't.
ecsfang
Posts: 35
Joined: Sun Jan 26, 2020 5:21 pm
Location: Lund/Sweden

Re: Editor bug using delete [VIDEO]

Post by ecsfang »

Hi Boubker,

See viewtopic.php?p=18374#p18374 for more information.
I guess your finding is similar to the problems reported there.

Best regards,
Thomas
[35/45/65/67/25/29C/31E/33E/41C|CV|CX/71B/10C/11C/15C/16C/32SII/42S/28S/48GX/49G/35S/DM41X(#00456)]
(7397)[134]
Boub65
Posts: 176
Joined: Tue Sep 12, 2017 4:34 pm
Location: Rabat, Morocco

Re: Editor bug using delete [VIDEO]

Post by Boub65 »

Hi Thomas,
Yes it is the same bug 😳 (I somehow missed your post)
PS: May be an admin can merge my post under yours
Sincerely,
Boubker.
Sincèrement, Sincerely, 73,
Boubker

2xDM15L, DM41L, DM42 SN#00855 (+one lost during shipping), DM41X #00707
TI-89 titanium, CASIO fx-cg50 (to play with micropython)

There are three kinds of people in the world: those who know math and those who don't.
Panchdara
Posts: 24
Joined: Sat May 15, 2021 9:02 am

Re: Editor bug using delete [VIDEO]

Post by Panchdara »

I concur. Seems if you add a label LBL(and I think other instructions with a second parameter - even with RCL 00 for instance) then add more lines then up or down line and then <- (backspace/delete) then multiple lines will be deleted.

I think the answer lies in when that label (2 parameter instruction) is added then a bug will happen at any time after when backspace is used on a line. Once that bug has been used then all is normal until another label is created.

This bug is easily 100% reproducible.

Best regards
Hugh
Panchdara
Posts: 24
Joined: Sat May 15, 2021 9:02 am

Re: Editor bug using delete [VIDEO]

Post by Panchdara »

Any follow up on this? Or is DM41X now not supported? Just curious now as little seems to be forthcoming.
rprosperi
Posts: 1182
Joined: Mon Apr 24, 2017 7:48 pm
Location: New York

Re: Editor bug using delete [VIDEO]

Post by rprosperi »

I'm not sure what you mean by "not supported"...

This bug has been verified and acknowledged and will eventually be corrected, however since there is no data-loss or incorrect results, and is only a visual glitch in rarely encountered situations, and even then, not in all edit modes, it's not a "big" enough problem to warrant attention. Yet.
--bob p

DM42: β00071 & 00282, DM41X: β00071 & 00656, DM10L: 071/100
Peet
Posts: 175
Joined: Tue Sep 29, 2020 12:01 am
Location: Germany

Re: Editor bug using delete [VIDEO]

Post by Peet »

Various small bugs and glitches have been known for almost a year now. The last firmware of the DM41X is over a year old and the DM41X still has DMCP version 3.20 although version 3.22 on the DM42 is already a several months old.

So far there are also no information about further work on this project. It is therefore not surprising that the impression arises that the DM41X project has been closed. Which, admittedly, wouldn't be a drama, since it works very well on the whole and the original HP41 didn't get any firmware updates either.
My programmable calculators - former: CBM PR100, HP41CV, HP28S, HP11C - current: HP48G(256kB), HP35S, Prime, DM41X, DM42
Post Reply