43S News

General discussion about calculators, Swiss Micros or otherwise
User avatar
ManuMa
Posts: 4
Joined: Sun Mar 15, 2020 9:14 pm
Contact:

Re: 43S News

Post by ManuMa » Sun May 10, 2020 4:41 pm

Hi Walter,
I have been happily using the 43S emulator for quite some time until about two or three versions ago. Since then, I get the error "Exception code=0xc000001d flags=0x0 at 0x000000000040658A"
I am using Windows 7 home. I have installed it on my son's win10 laptop without issues.
I have deleted everything, and installed again as per the readme.md file:
Reinstalled the last gtk3-runtime for win64.
Reinstalled the last WP43S_StandardFont.ttf font.
Copied the last wp43s.exe, wp43s_pre.css and the artwork folder to the directory containing the emulator.
No backup.bin present.
wp43s.exe still does not work.
BTW, never been able to run the wp43c emulator. Always gave the same error as wp43s gives now.
Any help will be greatly (and I mean it) appreciated,

Regards,
Manuel.

Nazar
Posts: 13
Joined: Sat May 09, 2020 6:54 pm
Location: Lahore, Pakistan

Re: 43S News

Post by Nazar » Sun May 10, 2020 5:13 pm

I have done all the steps in the README when installing to get this error.
HP-28s, HP-28C, HP-35s, DM-42, Casio fx-570EX

User avatar
Over_score
Posts: 84
Joined: Fri May 05, 2017 7:37 pm
Location: France

Re: 43S News

Post by Over_score » Sun May 10, 2020 5:35 pm

As I said in a precedent post:
The "0xc000001d" error is commonly caused by incorrectly configured system settings or irregular entries in the Windows registry.
All I can suggest is to make a fresh install of Windows.
DM42 (SN 00284 & 03835), DM15L, HP41CV, HP42S, HP35s, WP34S, HP Prime

User avatar
Walter
Posts: 1469
Joined: Tue May 02, 2017 9:13 am
Location: Close to FRA, Germany

Re: 43S News

Post by Walter » Sun May 10, 2020 7:19 pm

ManuMa wrote:
Sun May 10, 2020 4:41 pm
I have been happily using the 43S emulator for quite some time ...
I am using Windows 7 home. I have installed it on my son's win10 laptop without issues.
...
wp43s.exe still does not work.
You know Win7 is a dead OS, don't you?
DM42 SN: 00041 Beta
WP 43S running on this device

HP-35, HP-45, ..., HP-50, WP 34S, WP 31S, DM16L

User avatar
ManuMa
Posts: 4
Joined: Sun Mar 15, 2020 9:14 pm
Contact:

Re: 43S News

Post by ManuMa » Sun May 10, 2020 7:32 pm

Thank you for the replies.
Walter, I still use my original 41CV, so I tend to use things while possible.
I have had the emulator working for a year maybe, and it worked nicely. It was one of the updates what caused the issue. Just before the update it was working, just after the update it was not. That's why I am so intrigued.
Thank you anyway. I'll keep trying, as I love the 43S.

Regards,
Manuel.

User avatar
akaTB
Posts: 454
Joined: Tue May 02, 2017 11:56 am
Location: Milan, Italy

Re: 43S News

Post by akaTB » Sun May 10, 2020 7:48 pm

Walter wrote:
Sun May 10, 2020 7:19 pm
ManuMa wrote:
Sun May 10, 2020 4:41 pm
I have been happily using the 43S emulator for quite some time ...
I am using Windows 7 home. I have installed it on my son's win10 laptop without issues.
...
wp43s.exe still does not work.
You know Win7 is a dead OS, don't you?
So what, Walter?
Do you think this could be related to the error shown? :roll:
Greetings,
    Massimo
ajcaton
-+×÷ left is right and right is wrong :twisted: Casted in gold

User avatar
Walter
Posts: 1469
Joined: Tue May 02, 2017 9:13 am
Location: Close to FRA, Germany

Re: 43S News

Post by Walter » Sun May 10, 2020 9:57 pm

akaTB wrote:
Sun May 10, 2020 7:48 pm
Walter wrote:
Sun May 10, 2020 7:19 pm
ManuMa wrote:
Sun May 10, 2020 4:41 pm
I have been happily using the 43S emulator for quite some time ...
I am using Windows 7 home. I have installed it on my son's win10 laptop without issues.
...
wp43s.exe still does not work.
You know Win7 is a dead OS, don't you?
So what, Walter?
Do you think this could be related to the error shown? :roll:
It's running under Win10 of Manuel's son - it's not running under Manuel's Win7. Martin recommended a fresh installation of the OS. So what's wrong in this context with pointing to Win7 being dead, Massimo? :? An update might well solve the problem easier and faster than digging in old bits.
DM42 SN: 00041 Beta
WP 43S running on this device

HP-35, HP-45, ..., HP-50, WP 34S, WP 31S, DM16L

User avatar
akaTB
Posts: 454
Joined: Tue May 02, 2017 11:56 am
Location: Milan, Italy

Re: 43S News

Post by akaTB » Mon May 11, 2020 6:30 am

Walter wrote:
Sun May 10, 2020 9:57 pm
akaTB wrote:
Sun May 10, 2020 7:48 pm
Walter wrote:
Sun May 10, 2020 7:19 pm

You know Win7 is a dead OS, don't you?
So what, Walter?
Do you think this could be related to the error shown? :roll:
It's running under Win10 of Manuel's son - it's not running under Manuel's Win7. Martin recommended a fresh installation of the OS. So what's wrong in this context with pointing to Win7 being dead, Massimo? :? An update might well solve the problem easier and faster than digging in old bits.
So you think that the day Microsoft doesn't deliver updates anymore, all of a sudden a computer stops working?
I can point you to many servers still running Windows 2003 (and win2000, too) because, for several reasons, applications running on them cannot be updated.

And it is easy to point to refreshing an installation: easier said than done, sometimes. Furthermore an update to 10 might even make things worse if you use older drivers that were never updated, as an example.
Probably a deeper cleaning of the registry is needed after uninstall.

That being said, and in absence of other (hw/sw) problems, I could suggest going to Win10 myself, so to use the improved WSL2 and native linux tools.
Greetings,
    Massimo
ajcaton
-+×÷ left is right and right is wrong :twisted: Casted in gold

User avatar
Walter
Posts: 1469
Joined: Tue May 02, 2017 9:13 am
Location: Close to FRA, Germany

Re: 43S News

Post by Walter » Mon May 11, 2020 6:57 am

akaTB wrote:
Mon May 11, 2020 6:30 am
Walter wrote:
Sun May 10, 2020 9:57 pm
It's running under Win10 of Manuel's son - it's not running under Manuel's Win7. Martin recommended a fresh installation of the OS. So what's wrong in this context with pointing to Win7 being dead, Massimo? :? An update might well solve the problem easier and faster than digging in old bits.
So you think that the day Microsoft doesn't deliver updates anymore, all of a sudden a computer stops working?
I can point you to many servers still running Windows 2003 (and win2000, too) because, for several reasons, applications running on them cannot be updated.

And it is easy to point to refreshing an installation: easier said than done, sometimes. Furthermore an update to 10 might even make things worse if you use older drivers that were never updated, as an example.
Probably a deeper cleaning of the registry is needed after uninstall.

That being said, and in absence of other (hw/sw) problems, I could suggest going to Win10 myself, so to use the improved WSL2 and native linux tools.
Massimo, pleae read thoroughly what I've written and what you think I have. I looked at the differences between two setups and suggested a solution. I didn't say Win7 doesn't work. You failed to suggest an alternative solution so far.
DM42 SN: 00041 Beta
WP 43S running on this device

HP-35, HP-45, ..., HP-50, WP 34S, WP 31S, DM16L

Nazar
Posts: 13
Joined: Sat May 09, 2020 6:54 pm
Location: Lahore, Pakistan

Re: 43S News

Post by Nazar » Mon May 11, 2020 7:58 am

Walter wrote:
Sun May 10, 2020 3:11 pm
Nazar wrote:
Sun May 10, 2020 11:47 am
Guys could you help me with the wp 43s windows binaries? I followed all the instructions to install and when i run wp43s.exe then I get an Entry Point Not Found error. It says that InflateReset2 could not be located in libpng16-16.dll
Please check the Reference Manual (https://gitlab.com/Over_score/wp43s/-/t ... umentation), page 206.
I have checked the reference manual on page 206 and I have followed all the instructions in (b) and the README to lead me to this problem. Is there a certain GTK3+ package that I have to install to get the entry point "inflateReset2" in libpng16-16.dll?
HP-28s, HP-28C, HP-35s, DM-42, Casio fx-570EX

Post Reply