Page 4 of 4

Re: Battery life

Posted: Mon May 20, 2019 6:49 pm
by akaTB
fkunz wrote:
Mon May 20, 2019 4:22 pm
Hello,

Is this problem fixed?

Yes it is, definitely, for me at least.
Try to contact David, he will probably have you try some measurements on your unit.

In the meantime you can try changing to one of the four different settings of Power OFF mode (shift + 0 [setup], 5, 2, 7) and see if it makes a difference.
The magic number for me is "1".

Good luck!

Re: Battery life

Posted: Mon May 20, 2019 7:11 pm
by budmur
akaTB wrote:
Mon May 20, 2019 6:49 pm

The magic number for me is "1".

This is my magic number as well. FWIW, my board is V3, Copyright Date 2017.

Re: Battery life

Posted: Sun Jul 14, 2019 3:27 pm
by ahz
Hi all

I received my DM42 around two month ago and i realy like it. But the battery consumption is a nightmare.

It takes two batteries within these two month but was not seriously used. To be honest, with the second battery it was only switched on to check the battery voltage and then switched off again. I did this only once a day.

When the DM42 was out off power from the first battery (didn't show any live signal) i replaced the battery and checked the voltage with a multimeter. It shows 2.5 Volt which is very high for an empty battery.

With the second battery this behaviour was observed, too. I activated the voltage display in the DM42. Last time the calculator was alive the voltage was around 2.6V.

Obviously a calcuator with this amount of battery consumtion is not acceptable if one want to use it seriously.
I tried changing the POWER OFF mode to 1 (from default 3) but it seems not to show any difference (quite subjective observation, of course).

Does anyone have a suggestion how to get rid of this problem?

My Firmware is DMCP v3.13 (IFC 3.10) and the Program is 3.13/2.0.24. Hardware SN: 03910

Kind regards
Andreas

Re: Battery life

Posted: Sun Jul 14, 2019 8:53 pm
by akaTB
ahz wrote:
Sun Jul 14, 2019 3:27 pm
Hi all

I received my DM42 around two month ago and i realy like it. But the battery consumption is a nightmare.

It takes two batteries within these two month but was not seriously used. To be honest, with the second battery it was only switched on to check the battery voltage and then switched off again. I did this only once a day.

When the DM42 was out off power from the first battery (didn't show any live signal) i replaced the battery and checked the voltage with a multimeter. It shows 2.5 Volt which is very high for an empty battery.

With the second battery this behaviour was observed, too. I activated the voltage display in the DM42. Last time the calculator was alive the voltage was around 2.6V.

Obviously a calcuator with this amount of battery consumtion is not acceptable if one want to use it seriously.
I tried changing the POWER OFF mode to 1 (from default 3) but it seems not to show any difference (quite subjective observation, of course).

Does anyone have a suggestion how to get rid of this problem?

My Firmware is DMCP v3.13 (IFC 3.10) and the Program is 3.13/2.0.24. Hardware SN: 03910

Kind regards
Andreas
Contact David @ swissmicros
He will probably ask you to make some test on your unit (or find its version, maybe) and give you hints on solving this problem.
In the meanwhile you can try to cycle through the various settings in Power Off mode and check if you see any difference.

Re: Battery life

Posted: Tue Jan 07, 2020 5:22 pm
by TwoWeims
What kind of Battery life should I be expecting?
Should it be comparable to a Pioneer or a Voyager? These are the only Coin Cell Type HP's I have experience with. I have a 15C and a 42S and the batteries last significantly longer than my DM42.

I have had the DM42 for about a year and am on my fourth or fifth battery. This is without extreme use.
I did my last replacement around Thanksgiving and have been away from the Office a significant amount of the time since then.
My DM42 has been sitting on the desk powered off for 95% of that time.
I came in yesterday to find the Battery Dead.

I installed a fresh battery and by today I am down to 2.86V. It was sitting on my desk powered off all night.

I think all my firmware is up to date. Here is my current version Information:

20200107-10134908.bmp
20200107-10134908.bmp (12.31 KiB) Viewed 1313 times

Re: Battery life

Posted: Tue Jan 07, 2020 6:20 pm
by Logan
I had one from the first production batch, I use it daily, written and use many programs, and it still shows full battery after two years, so presumably that's much closer to "normal" than you're getting.

Re: Battery life

Posted: Tue Jan 07, 2020 6:55 pm
by Walter
Logan wrote:
Tue Jan 07, 2020 6:20 pm
I had one from the first production batch, I use it daily, written and use many programs, and it still shows full battery after two years, so presumably that's much closer to "normal" than you're getting.
That's a keen assumption. Industrial quality would be if the battery life you observe with your device would be really normal with very few and only little deviations. Seems this quality is yet to be achieved - but only Michael and David know the production statistics if any.

Re: Battery life

Posted: Sat Jan 18, 2020 12:40 am
by tycho
I too have the original battery (first batch from release day), and it's still full and good voltage. Admittedly, I only use it a few times a month, but do update to latest firmware nearly every release. Could later batches have worse battery life, or if it is just a few in between? Actually my HP12C with double CR2032 battery ran out faster than the Dm42.

Re: Battery life

Posted: Sat Jan 18, 2020 12:53 am
by TwoWeims
I sent an e-mail to SwissMicros about a week ago. No response at all.

Maybe they are too busy preparing the DM41X?

Re: Battery life

Posted: Sat Jan 18, 2020 1:47 am
by Richard Garner
Hello,

I had battery problems with my copyright 2017 DM42 but not my 2018, When DMCP 3.9 firmware and up came out the battery problem was solve. Upon reseting the system upon installing a new firmware the system is suppose to detect the type of motherboard and set the mode for the OFF Power current. If it needs to be ajusted you can go into SETUP, SYSTEM, OFF current use and set the Mode manually to 1, 2 or 3. I have not had any problems sense.