I failed in updating firmware V3.1

Post here to share useful tips and tricks, to ask questions about using your DM42 or to report software-related problems
User avatar
akaTB
Posts: 479
Joined: Tue May 02, 2017 11:56 am
Location: Milan, Italy

Re: I failed in updating firmware V3.1

Post by akaTB » Sat Dec 23, 2017 9:11 pm

Mark Hardman wrote:
Sat Dec 23, 2017 8:56 pm
I'm curious why the OP felt the need to update the QSPI. It is clear from grsbank's 3.1 announcement that the update is not needed:

"The QSPI chip's contents remains the same for versions 2.11.6, 3.0 and 3.1."

Perhaps a stronger warning in the release notes would deter people from needlessly performing the update.

Because both the flash and the QSPI bin files are available in the firmware update directory at https://www.swissmicros.com/dm42/firmware, there is an additional enticement to new users to download and apply both files. Might I suggest placing the QSPI files in a different directory and only include it in the firmware update directory when it is actually necessary.

Just a thought,

Mark Hardman
When it happened to me I didn't want to flash the QSPI, I had to do it when the menu instructed me to do so: I was downgrading firmware version since my unit started to act strangely (in hindsight because of QSPI fault).
Greetings,
    Massimo
ajcaton
-+×÷ left is right and right is wrong :twisted: Casted in gold

User avatar
Mark Hardman
Posts: 108
Joined: Wed May 03, 2017 1:26 am
Location: Houston, TX

Re: I failed in updating firmware V3.1

Post by Mark Hardman » Sat Dec 23, 2017 9:25 pm

akaTB wrote:
Sat Dec 23, 2017 9:11 pm
When it happened to me I didn't want to flash the QSPI, I had to do it when the menu instructed me to do so: I was downgrading firmware version since my unit started to act strangely (in hindsight because of QSPI fault).
I agree with you that there will be circumstances where the QSPI will need to be re-flashed. I'm just suggesting that its download be segregated from the normal flash updates and that the release notes emphasize that the QSPI does not need to be flashed.

Mark Hardman
DM42: β00043, β00065, 00357 / DM41X: β00054
DM10L: 017/100, DM11L: 00121, DM12L: 02005, DM15L: 00523, DM16L: 00008, DM41L: 00111

rprosperi
Posts: 842
Joined: Mon Apr 24, 2017 5:48 pm
Location: New York

Re: I failed in updating firmware V3.1

Post by rprosperi » Sun Dec 24, 2017 4:22 am

Mark Hardman wrote:
Sat Dec 23, 2017 8:56 pm
Might I suggest placing the QSPI files in a different directory and only include it in the firmware update directory when it is actually necessary.

Just a thought,
1 +

A darn good thought... I was preparing to suggest the same thing, but instead I can endorse yours. It most certainly will happen again, just because it can.

Merry Christmas
--bob p

DM42: β00071 & 00282, DM41X: β00071, DM10L: 071/100

Nobody
Posts: 10
Joined: Fri Nov 24, 2017 11:03 pm
Location: Tokyo

Re: I failed in updating firmware V3.1

Post by Nobody » Sun Dec 24, 2017 5:44 am

David wrote:
Sat Dec 23, 2017 7:32 pm
Good, we have to find some starting point here. Please, do following steps:
- From "QSPI Load" menu select 1. Bootloader
- start dm_tool and flash DM42_flash_3.1.bin
- Calculator should start again in "QSPI Load" menu
- Select 5. FAT Disk Media Test > 2. Test and Format FAT
- After that you should be able to run 3. Activate USB disk and see the calc disk with /PROGRAM and /STATE folders
- copy DM42_qspi_3.1.bin to the root of the disk (don't forget correctly eject the disk so the contents could be properly written)
- Then 2. Load QSPI from FAT
After restart the calc should be OK.

Please, let me know where the process eventually fails in this list.
Thank you every one who helped me here.
I managed to solve the problem. Now my DM42 seems to work fine.
I still do not know what was wrong, and why that could be solved.

The procedure is as follows;
- From "QSPI Load" menu select 1. Bootloader ---> done
- start dm_tool and flash DM42_flash_3.1.bin ---> done
- Calculator should start again in "QSPI Load" menu ---> yes

- Select 5. FAT Disk Media Test > 2. Test and Format FAT ---> done but failed at first
At the first try, failed at progress 0 % with ERROR:0a09. Then I had to RESET.
At the 2nd try, stopped at progress 8 % with ERROR:0a09. Again I had to RESET.
I continued to try the same routine more than 10 times, before the LCD shows progress 100 % without ERROR at last.

- After that you should be able to run 3. Activate USB disk and see the calc disk with /PROGRAM and /STATE folders ~~~> Yes, then I could see the folders.

- copy DM42_qspi_3.1.bin to the root of the disk (don't forget correctly eject the disk so the contents could be properly written)
---> Finally done, but I had to try this routine almost 10 times to proceed progress.
At first, the copy stopped at progress 18% with ERROR 0a09. I had to try several times to clear this 18 % barrier.
The next barrier was 74 %. Before successfully copying 100 % , I had to write the file agin and again.

- Then 2. Load QSPI from FAT ---> Finally done. More than 10 times I had to try this routine again and again.
At first, the flashing process stopped at 0 % progress with ERROR 0a09.
At the 2nd attempt, flashing stopped at 1% with ERROR 0a09
After more than 10 times try, the flashing ended with success.

And one point I had to say. Before the flashing successfully ended, there was a 76 % barrier.
Several times I tried but always the flashing stopped at progress 76 %. Then I started the flashing without USB connection, it was just occurred to me. And after I connected the USB, the flashing continued to normal end with 100 % progress.
M.K.

25C, 29C, 67, 41CV, 41CX, 42S, 15C, 28S, 48SX, 48GX, Prime,
and DM42 SN:00176

User avatar
akaTB
Posts: 479
Joined: Tue May 02, 2017 11:56 am
Location: Milan, Italy

Re: I failed in updating firmware V3.1

Post by akaTB » Sun Dec 24, 2017 8:51 am

Good!
A merry Christmas in Tokyo too. :)

I was more lucky: I tried two, maybe three, times before succeeding.

Agreed: looks like QSPI updates should be kept to a minimum.
Greetings,
    Massimo
ajcaton
-+×÷ left is right and right is wrong :twisted: Casted in gold

grsbanks
Posts: 921
Joined: Tue Apr 25, 2017 9:23 am
Location: Preston, Lancs, UK
Contact:

Re: I failed in updating firmware V3.1

Post by grsbanks » Sun Dec 24, 2017 8:56 am

Glad you got it sorted! That one appeared to be a difficult customer and I think we've seen one other machine like that during beta testing.

Like you, the user persevered and the unit has been working perfectly since then so there's every reason to expect that you will have no further problems like this.

One word of caution. When it says "the QSPI contents remains unchanged" in the release notes, there's no need to flash it, just the DM42_flash_v#.#.bin file! I think I'll take Mark up on his suggestion because it makes a lot of sense...
There are only 10 kinds of people in the world: those who understand binary and those who do not.

David
Posts: 17
Joined: Fri Apr 07, 2017 5:32 am

Re: I failed in updating firmware V3.1

Post by David » Sun Dec 24, 2017 9:42 am

Very well, we are glad it is successfully solved.

The problem is we have still old dm_tool on the web. We have prepared new version with 'tuned' QSPI settings which should be far more stable during the QSPI updates. And as we learned here, we have to issue updated version as soon as possible.

jfb9301
Posts: 21
Joined: Sun Dec 10, 2017 11:33 pm

Re: I failed in updating firmware V3.1

Post by jfb9301 » Sun Dec 24, 2017 11:09 am

Not including the QPSI might lead to some challenges.

Hypothetical scenario:
3.1 no QPSI update
3.2 QPSI update
3.3 no QPSI update
3.4 no QPSI update

A hypothetical user who has 3.1 installed waits a long time to update. When next they go to update 3.5 has been released. 3.5's release notes say that no update is necessary, so they do not update it. If I understand how this works, the calculator will let you know that you do need a QPSI update, but now the user needs to download backwards to 3.2 to find the update they need. The only idea of how to tackle this is separate both downloads and put the caution and notes on the download page. Maybe someone has another, better, idea.

User avatar
Mark Hardman
Posts: 108
Joined: Wed May 03, 2017 1:26 am
Location: Houston, TX

Re: I failed in updating firmware V3.1

Post by Mark Hardman » Sun Dec 24, 2017 4:52 pm

jfb9301 wrote:
Sun Dec 24, 2017 11:09 am
Not including the QPSI might lead to some challenges.

Hypothetical scenario:
3.1 no QPSI update
3.2 QPSI update
3.3 no QPSI update
3.4 no QPSI update

A hypothetical user who has 3.1 installed waits a long time to update. When next they go to update 3.5 has been released. 3.5's release notes say that no update is necessary, so they do not update it. If I understand how this works, the calculator will let you know that you do need a QPSI update, but now the user needs to download backwards to 3.2 to find the update they need. The only idea of how to tackle this is separate both downloads and put the caution and notes on the download page. Maybe someone has another, better, idea.
A very good point. Perhaps when the DM42 gives notification that the QSPI needs to be updated it could also include the URL needed to get the latest update.
DM42: β00043, β00065, 00357 / DM41X: β00054
DM10L: 017/100, DM11L: 00121, DM12L: 02005, DM15L: 00523, DM16L: 00008, DM41L: 00111

Bunuel66
Posts: 6
Joined: Sun Nov 26, 2017 9:25 am

Re: I failed in updating firmware V3.1

Post by Bunuel66 » Tue Dec 26, 2017 10:22 pm

Same problem here.....I'm in the very tedious process of reformating the FAT disk (currently stuck at about 50%).
I'm suspecting that some chips have a Flash chip corrupted or at least that the sector table is corrupted
in some way.
A little bit disappointing....;-(

Regards

Post Reply