Font question

Post here to share useful tips and tricks, to ask questions about using your DM42 or to report software-related problems
Post Reply
tgray
Posts: 26
Joined: Fri Jul 28, 2017 3:36 am

Font question

Post by tgray »

I've noticed with certain complex numbers (and maybe others), the classic and new fonts display differently. Try the following in ALL display mode:

Code: Select all

.1
LN
LN
The new font shows

Code: Select all

834.E-3 i3.14E0
while the old font shows

Code: Select all

8.34032445248E-1 i3.
I have my font size at the second largest setting. Other sizes display differently between the two fonts as well. I think the two smallest font sizes display the same with both fonts.

What is the reasoning behind this? I feel like the display truncation that the new font uses is more useful.
Dave Britten
Posts: 128
Joined: Wed Jun 14, 2017 9:27 pm

Re: Font question

Post by Dave Britten »

That's peculiar. Your first (new font) example just looks likes ENG 02 display mode. I tried reproducing this on mine, but couldn't. I was thinking maybe it remembered which display mode you had selected for each font, but that doesn't seem to be the case.
grsbanks
Posts: 1087
Joined: Tue Apr 25, 2017 11:23 am
Location: Preston, Lancs, UK
Contact:

Re: Font question

Post by grsbanks »

Thanks for the report. We're looking at it.
There are only 10 kinds of people in the world: those who understand binary and those who do not.
grsbanks
Posts: 1087
Joined: Tue Apr 25, 2017 11:23 am
Location: Preston, Lancs, UK
Contact:

Re: Font question

Post by grsbanks »

The bug has been found and fixed. This will work as expected in V3.1, which is imminent. Keep an eye on the "Firmware Update announcement" section of this forum.
There are only 10 kinds of people in the world: those who understand binary and those who do not.
Post Reply