[SOLVED] DM42 double mounted in Linux

Post here to share useful tips and tricks, to ask questions about using your DM42 or to report software-related problems
Post Reply
User avatar
Posts: 170
Joined: Fri Dec 15, 2017 1:34 pm
Location: GB-MAN

[SOLVED] DM42 double mounted in Linux

Post by ijabbott » Sun Dec 09, 2018 8:05 pm

I had a problem where every time I plugged in the DM42 in one of my Linux systems and activated the USB disk from the DM42 menus, it would get automatically mounted in two places simultaneously, once in /media/ian/DM42 (my username being "ian"), and once in /media/usb0. After I'd finished transferring files, I needed to unmount it twice from the GNOME file manager (Nautilus) to make sure it was really unmounted, and I was a bit uneasy about the effects the double mounting and unmounting would have on the underlying file system of the DM42. What's more, the second unmounting from /media/usb0 would prompt me to enter my password, which was a bit annoying.

I considered the /media/ian/DM42 mount point-point to be the "normal" one for a desktop environment on Debian or Ubuntu (some other distros use a different path, I think), as controlled by the udisks2 package. I considered the /media/usb0 mount-point to be spurious, and didn't know what was causing the DM42 to get mounted there until today. I discovered the culprit was the usbmount package which I'd installed earlier in the year for some reason (possibly something to do with retro gaming via EmulationStation). Uninstalling usbmount fixed the double mounting problem for me. The DM42 was automounted to /media/ian/DM42 only, and I could unmount it without having to enter my password.

I'm just posting this here in the unlikely event that someone runs into the same problem I had!

Post Reply