DM42 Firmware V3.2 available

This is where announcements of firmware updates for the DM42 calculator will be made
Dani R.
Posts: 285
Joined: Fri May 05, 2017 8:23 pm

Re: DM42 Firmware V3.2 available

Post by Dani R. » Sun Jan 07, 2018 11:24 am

rprosperi wrote:
Sat Jan 06, 2018 12:55 am
dlachieze wrote:
Fri Jan 05, 2018 11:41 pm
The update to 3.2 with dm_tool 2.3 was smooth but then I tried to transfer some OFFIMG files and it hung. The DM42 was unresponsive, stuck in USB disk mode, but not anymore recognized by Windows. I had to reset it with a paperclip, then everything worked fine and I was able to transfer the images.
I just had the exact same issue occur; was just coming here to report this and saw Didier's note.

Initially the USB drive connected, then before anything was transferred, it just disconnected (on the PC side - the drive window closed) but the DM42 was frozen in the connected state. The DM42 would not respond to the [EXIT] key. I disconnected the USB cable, and pressed reset with a paperclip. The About screen appeared, and then the DM42 was OK. I then connected again and had no trouble copying files to the USB drive, deleting files on the drive, etc. All seems OK now.
Windows 7 Pro 64; First I updated my beta unit from 3.1 to 3.2. Then I removed the DM42, switched the unit off and turned it on. Then I reconnected the DM42 and activated the USB. Since I always work with TotalCommander, I have compared my backup with the contents of FAT_16. TC hung up, I could not quit it with the TaskManager. It was not possible to eject FAT_16. Cable removed, reset of DM42 with paper clip. I never had a problem with the USB mode of the DM42 before.
DM42 SN:00032

User avatar
Posts: 21
Joined: Sat Jul 22, 2017 10:21 pm
Location: Portugal

Re: DM42 Firmware V3.2 available

Post by Jebem » Sun Jan 07, 2018 6:19 pm

Thomas Okken wrote:
Sat Jan 06, 2018 4:42 am
budmur wrote:
Sat Jan 06, 2018 4:19 am
What are the consequences of the lower level of code optimization? Is it slower, larger file sizes, or something else?
Also: what exactly are the before and after optimization settings, and does this apply to compiling Free42, the DM42 OS, or both?

I have been reading the STM application notes, and one thing that I have been overlooking is that this DM42 operating system code is distributed among two memory code regions, one being internal to the processor, and another is external on the Quad-SPI 64Mbit flash ROM.

If I understood correctly from a few posts elsewhere, the external Quad-SPI 64Mbit flash ROM contains the Intel math library.

So, most high level Free42 calculator functions will result in low level machine instructions pointing to memory addresses located on those two distinct hardware memory devices.

Assuming that hardware design flaws can safely be excluded after such a long alpha and beta testing, I wonder if the hung issue detected by some of the DM42 owners could be related to a timing component setup when the STM SoC processor needs to address the external Quad-SPI chip, namely the STM software setup for the number of dummy cycles (DCYC[4:0] field QUADSPI_CCR register) to ensure that the turnaround time between output mode and input mode at the bus signal is large enough to let the Quad-SPI chip run within its worse case scenario latency response.

Just guessing here, but this is one of the most common issue resulting in hung situations on any computer, when all other running parameters are correct (power supply, temperature, among a few others).
Just look to the overclock settings on a x86/x64 PC BIOS: Each individual PC needs to be tuned to the correct DRAM memory wait cycles every time one replaces a DIMM, even if the DIMMs have the same brand and reference. Slight variations in the DRAM response times can result in a hung situation if the BIOS settings are too tight. This hung looks to be intermittent, but it is not, as it will depend on a number of other factors besides the RAM access time variations, like temperature and power supply.

So, that "lower level code optimization" done on this V3.2 f/w may have resulted in the insertion of extra dummy cycles to make sure that all the Quad-SPI flash ROM chips and STM SoC processors, with their small speed variations, are not running at the edge of losing the correct synchronized operation.
Like one used to do on PC overclocking, setting the memory access a little bit slower will result in some performance loss, but will also result in a stable operation under most of the worst case scenarios.

Posts: 23
Joined: Wed Jun 07, 2017 2:23 pm

Re: DM42 Firmware V3.2 available

Post by NYC41 » Sun Jan 07, 2018 10:42 pm

Used dfu-util (MacOS Homebrew) without a problem. Thanks for the update - I'm now on the "production" firmware!
DM42 SN: 00085
HP-01; HP-41C, CV, CX, CL, CY; DM41L
(and many, many others)

Posts: 842
Joined: Mon Apr 24, 2017 5:48 pm
Location: New York

Re: DM42 Firmware V3.2 available

Post by rprosperi » Sun Jan 07, 2018 11:16 pm

I just had a repeat of the USB Drive lockup problem after updating my beta unit v3.1 -> v3.2.


1. Connect USB cable from Win-7x64 PC to DM42
2. Put device into bootloader mode
3. Run dm_tool.exe (v2.3)
4. Open DM42_flash_3.2.bin image file
5. Click [Program] to start update
6. When update completes, DM42 restarts, goes to About screen
7. Power DM42 off
8. Disco USB cable
9. Close dm_tool.exe
10. Insert USB cable
11. Power-on DM42
12. Shift-SETUP-1-3 to activate USB disk
13. Autoplay opens on PC, click to open DM42 virtual drive
14. 5 Folders appear
15. Open OFFIMG folder (4 files present)
16. Drag file from OFFIMG folder to desktop [OK]
17. Drag file to OFFIMG folder ==> Lockup
18. Disconnect USB cable
19. Rest DM42 with paperclip
20. Connect USB cable
21. Shift-SETUP-1-3 to activate USB disk
22. Autoplay opens on PC, click to open DM42 virtual drive
23. 5 Folders appear
24. Open OFFIMG folder (Folder is now empty)
25. Drag files PC -> OFFIMG Folder [OK]
26. Press [EXIT] to close USB virtual drive

DM42 is now acting properly again.

Something weird going on for sure.
--bob p

DM42: β00071 & 00282, DM41X: β00071, DM10L: 071/100

Posts: 88
Joined: Mon Jul 24, 2017 1:19 pm
Location: Germany

Re: DM42 Firmware V3.2 available

Post by Thomas_ER » Mon Jan 08, 2018 6:43 am

grsbanks wrote:
Fri Jan 05, 2018 7:47 pm
Release notes
Force RESET after flashing

A while ago some beta testers reported their DM42 hanging when waking up after a firmware update. This was caused by garbage data potentially remaining in the CPU's registers before booting up the firmware so we now do a full reset of the CPU to ensure a clean state.
Thank you for the new firmware!

Regarding the reported issues with the USB virtual drive, could this be an side-effect of "Force RESET after flashing"?
Will there be some sort of checking/debugging this issue?
Should we (me) wait for a possible V3.2.1?

Many thanks in advance!
[ HP48/49/50/42S/WP34/HP Prime/ DM42 (#00185+00318) ]

Posts: 920
Joined: Tue Apr 25, 2017 9:23 am
Location: Preston, Lancs, UK

Re: DM42 Firmware V3.2 available

Post by grsbanks » Mon Jan 08, 2018 12:32 pm

We're looking into the issue.

There were already some fixes and improvements scheduled for the next version, 3.3, so the fix for this won't be in there but rest assured that it is under investigation and will be dealt with once the root cause is identified.
There are only 10 kinds of people in the world: those who understand binary and those who do not.

User avatar
Posts: 122
Joined: Mon Apr 24, 2017 5:48 pm

Re: DM42 Firmware V3.2 available

Post by revwillie » Mon Jan 08, 2018 6:21 pm

revwillie wrote:
Fri Jan 05, 2018 7:53 pm
using DM tool 2.3, I sucessfully flashed v3.2 in windows7 64bit. So far, so good.
I should note that after I posted that, I experienced the same USB drive lock up reported by others. I was trying to update the HELP file at the time. I should have updated right away but got pulled away for other matters.
DM42 SN: 00076
DM15, HP 28c, HP 12c, HP 10b, HP 20b, HP 30b, HP 17bII, HP 42s, HP 35s, WP 34s, NP-25, TI-83+, teenix multicalc

User avatar
Posts: 122
Joined: Mon Apr 24, 2017 5:48 pm

Re: DM42 Firmware V3.2 available

Post by revwillie » Mon Feb 05, 2018 4:16 pm

Well, I was modifying files in the OFFIMG directory this morning and the calc froze. I did the paperclip reset. Then I got the error below and after pressing EXIT, the FAT disk state is now NOT READY.
USBerror.jpg (18.84 KiB) Viewed 3978 times
...running FAT disk media test....

OK I ran media test and it came out OK. reformatted FAT disk...was reloading Programs and the help file when the same problem occurred.

this time, the same Reg Id d3770002 was displayed. I'm going to try a new battery. I have not soldered the jumper onto my beta unit PCB. I have not received any errors or warnings about low battery.
DM42 SN: 00076
DM15, HP 28c, HP 12c, HP 10b, HP 20b, HP 30b, HP 17bII, HP 42s, HP 35s, WP 34s, NP-25, TI-83+, teenix multicalc

Krauts In Space
Posts: 85
Joined: Wed Jan 03, 2018 2:48 pm
Location: Nuremberg, Germany

Re: DM42 Firmware V3.2 available

Post by Krauts In Space » Mon Feb 12, 2018 9:13 am

akaTB wrote:
Fri Jan 05, 2018 10:20 pm
Geoff Quickfall wrote:
Fri Jan 05, 2018 10:01 pm
What an ease and pleasure to update. It is like christmas every time!

BUT :|

1) no T+X in catalogue and

2) no -1h in settings.


3) no book on shelves. :lol:
Besides I have noooo idea what's this "book" all about, with FW v3.3 I have at least the -1h option exists.
First I wanted to moan that I can't setup date display as D/M/Y, but with D/M/Y in FCN it works. This doesn't help it I want to hand programs and date display differnt, but at least it works. Still it would be neat to switch D/M/Y <> M/D/Y in setup menu.
But hey, If i wanted a clock I'd buy one ;)
DM15L S/# 10584 FW v25
DM42 S/# 01015 FW v3.5

User avatar
Posts: 1540
Joined: Tue May 02, 2017 9:13 am
Location: Close to FRA, Germany

Re: DM42 Firmware V3.2 available

Post by Walter » Mon Feb 12, 2018 9:45 am

Krauts In Space wrote:
Mon Feb 12, 2018 9:13 am
... I have noooo idea what's this "book" all about ...
FYI, "this book" is a generously illustrated monography by Geoff about 'restoring and repairing HP calculators' IIRC. Alas, I must write 'IIRC' since this publication was announced in writing many years ago. I saw an 'almost ready' printout some 5 years ago when meeting Geoff in Mainz. In fact, I've given him two WP calculator manuals in advance for his book then -- it should have been delivered to me some months later. Alas, no book in return so far. Many members of the MoHPC wait for it for years as well ...

Hope this explains the topic in brief. :(
DM42 SN: 00041 Beta
WP 43S running on this device

HP-35, HP-45, ..., HP-50, WP 34S, WP 31S, DM16L

Post Reply