Do not use Firmware V30 for DM1x/41

Firmware updates will be announced in this forum. The forum is marked as read-only, so if you have a problem with a new version then please report it in either the "DM1x/DM41 Usage tips, tricks and questions" forum or if you think it is a bug, then in the "DM1x/DM41 Bug reports" forum.
Post Reply
Posts: 900
Joined: Tue Apr 25, 2017 9:23 am
Location: Preston, Lancs, UK

Do not use Firmware V30 for DM1x/41

Post by grsbanks » Fri May 22, 2020 1:27 pm

A problem in V30 firmware for the DM1x and DM41 models has been identified.

The problem causes excessive load on the battery, which is depleted far sooner than it should be.

Investigations are under way to determine the cause of this problem, but in the meantime we recommend that you downgrade to V29 firmware.

Details of the V29 firmware can be found here: viewtopic.php?f=12&t=2192
Not SwissMicros staff, just an enthusiast.

Posts: 11
Joined: Sat Mar 07, 2020 5:35 pm
Location: UK

Re: Do not use Firmware V30 for DM1x/41

Post by AlanW » Fri May 22, 2020 4:16 pm

That explains why I have had to replace the battery of my new dm15L after about 2 months, and when powered on the low battery indicator was on and the display blanked shortly after each key press. E+ON gave a battery reading of zero, and shortly afterwards the calculator went into a deep sleep, only to be re-awakened with a new premium battery, which gave a reading of 3.05V. However after about a week the battery is at 2.775 volts, which suggests about a month's run time down to 2V. Obviously battery life depends on how much usage the calculator is getting, so this isn't very scientific. I'm curious to know what other people have seen. Is the problem with high standby current? Presumably the problem occurs on older calculators which behaved normally, until the upgrade. Mine's only ever had V30 on it.

I'll take a look at how to flash the firmware. Probably leave it a day or two just in case any fresh news come out on the subject.

EDIT: Programming issue SOLVED eventually. Might be you have to hit reset very quickly after message comes up

Update: I tried to Flash it and it failed to program. However battery voltage now down to 2.6V after flash attempt. Recovered later to 2.715V

Update2: Serial Console works, but battery dropped to 2.45V. I am wondering whether the Canon Camera cable I am using is fully wired. Perhaps it lacks the power wiring. I don't have another cable with the correct connector to try at the moment.

Update3: Ordered another cable, hopefully will arrive next week.

Update 4: Got new cable: Battery voltage still drops during serial console but perhaps not as much. Tried to program several times. Goes into Serial Console when reset pressed, but no programming appears to take place. Calculator eventually goes to PR Error. On E-ON version is still V30. Out of ideas. Looks like I'm stuck with V30. I know the comms works, because communication works fine with Putty and the hp15c simulator. I'm using 38400 baud with Putty. What baud rate does the updater use. Computer on latest Win 10 update. Any ideas anyone, I'm kind of stuck.

Update 5: Tried different computer with new cable. First time failed to program. Tried again and SUCCESS. I did press the Reset button immediately the message came up on the screen this time (getting impatient). Anyway, downgrade to V29 now complete. It'll be interesting to see if there is any difference in battery performance.


Posts: 1
Joined: Sun May 24, 2020 4:41 pm

Re: Do not use Firmware V30 for DM1x/41

Post by johanw » Sun May 24, 2020 8:24 pm

I had the same issue: I had recently ordered a DM15 that came with v30, and it took several tries before the firmware update tool recognized my calculator but I finally succeeded in flashing v29 firmware. I used a mini USB cable from an old phone.

I just ordered a DM15L and got confirmation it was being sent out today (on sunday, what a service), I'm curious with what firmware it will arrive.

Edit: the unit arrived today and it came with v30 installed. This time the update program recognised the unit directly (using the same cable) so I could flash v29.

Post Reply