DM15 old and new bugs

If you think you've found a bug in one of these machines, post about it here indicating the steps you perform in order to reproduce it.

Please prefix your topic with the model number in question and firmware version this way:

[DM16 V22] CHS gives unexpected results
Post Reply
J-F Garnier
Posts: 6
Joined: Sun Mar 11, 2018 4:37 pm
Location: France

DM15 old and new bugs

Post by J-F Garnier » Wed Mar 14, 2018 7:38 pm

I recently went back to some personal studies on the hp15c system, and pulled out my old 2012 "DM15CC" to test a few ideas.
I updated it with the latest firmware (V16) available for this first generation machine (that was still in V8 up to now) and I was suprised to discover again an old bug related to the integrate function in the M80 version, that can corrupt memory. The bug is only present in the M80 version and was supposed to be fixed since a long time.

To reproduce the bug with the M80 version:
starting from an empty machine (Pr error),
key-in this small test program (to make integrate do something):
001 42,21,11 LBL A
002 43 11 X^2
003 43 32 RTN
then do:
4 ENTER 7 DIM A
2 ENTER 2 DIM B
MATRIX 1
RCL B ; this checks B[1,1]=0
0 ENTER 1 Integrate A
RCL B ; B[1,1] is corrupted !

This is the bug I reported to SwissMicros in 2012 and that was fixed in M80_V2 , see the firmware history !
I'm sure it was still fixed in M80_V8 (that I used a lot) and so should have appeared again later. I believe (but I didn't check on the actual machine) that it appeared again in V12.
Can someone confirm the bug is still present in the latest M80 versions (can't check on my early machine)?

Conclusion: don't use the M80 versions for serious work.
(you may ask why I've been using the M80 version rather than the full-power M1B version; well it was related to my own hp15c emulation activities of the time... now I switched my DM15 to the M1B version)

A second bug (minor):
This second bug is minor, but it seems it has not been reported yet. I checked in on versions V8 and V16.
If there is no program step and if all memory is allocated to user registers and matrices, then the MEM display shows 256 free registers instead of 0.
Starting with a M1B version:
MEM: 19 211 0-0
3 ENTER 33 DIM A
4 ENTER 28 DIM B
MEM: 19 256 0-0

J-F

grsbanks
Posts: 882
Joined: Tue Apr 25, 2017 9:23 am
Location: Preston, Lancs, UK
Contact:

Re: DM15 old and new bugs

Post by grsbanks » Wed Mar 14, 2018 9:19 pm

J-F Garnier wrote:
Wed Mar 14, 2018 7:38 pm
A second bug (minor):
This second bug is minor, but it seems it has not been reported yet. I checked in on versions V8 and V16.
If there is no program step and if all memory is allocated to user registers and matrices, then the MEM display shows 256 free registers instead of 0.
Starting with a M1B version:
MEM: 19 211 0-0
3 ENTER 33 DIM A
4 ENTER 28 DIM B
MEM: 19 256 0-0
Still present in V25.
Not SwissMicros staff, just an enthusiast.

grsbanks
Posts: 882
Joined: Tue Apr 25, 2017 9:23 am
Location: Preston, Lancs, UK
Contact:

Re: DM15 old and new bugs

Post by grsbanks » Fri Mar 16, 2018 9:34 am

The corruption of matrix data does not happen with M80 version 25. I just checked.

Edit: I should have checked better. Corruption was occurring with V25.
Not SwissMicros staff, just an enthusiast.

J-F Garnier
Posts: 6
Joined: Sun Mar 11, 2018 4:37 pm
Location: France

Re: DM15 old and new bugs

Post by J-F Garnier » Sat Mar 17, 2018 4:23 pm

grsbanks wrote:
Fri Mar 16, 2018 9:34 am
The corruption of matrix data does not happen with M80 version 25. I just checked.
What is the default memory allocation in V25? V16 is MEM: 30 99 0-0
If V25 is different, can you check again with this memory allocation. The affected registers are depending on it.

J-F

grsbanks
Posts: 882
Joined: Tue Apr 25, 2017 9:23 am
Location: Preston, Lancs, UK
Contact:

Re: DM15 old and new bugs

Post by grsbanks » Sun Mar 18, 2018 10:58 am

J-F Garnier wrote:
Sat Mar 17, 2018 4:23 pm
grsbanks wrote:
Fri Mar 16, 2018 9:34 am
The corruption of matrix data does not happen with M80 version 25. I just checked.
What is the default memory allocation in V25? V16 is MEM: 30 99 0-0
If V25 is different, can you check again with this memory allocation. The affected registers are depending on it.
It is also 30 99 0-0 but I was wrong. Corruption did occur with V25.
Not SwissMicros staff, just an enthusiast.

J-F Garnier
Posts: 6
Joined: Sun Mar 11, 2018 4:37 pm
Location: France

Re: DM15 old and new bugs

Post by J-F Garnier » Sun Mar 18, 2018 2:48 pm

grsbanks wrote:
Sun Mar 18, 2018 10:58 am
J-F Garnier wrote:
Sat Mar 17, 2018 4:23 pm
What is the default memory allocation in V25? V16 is MEM: 30 99 0-0
If V25 is different, can you check again with this memory allocation. The affected registers are depending on it.
It is also 30 99 0-0 but I was wrong. Corruption did occur with V25.
Thanks for confirming.

I was asking about the memory allocation in M80 version because the model page states (thus incorrectly) that the M80 memory configuration is:
DM15_M80 19 110 0-0

J-F

Post Reply