Printing issue

Post here to share useful tips and tricks, to ask questions about using your DM42 or to report software-related problems
Post Reply
mezoganet
Posts: 41
Joined: Tue Jan 22, 2019 12:54 pm
Location: Tours, France

Printing issue

Post by mezoganet » Tue Jan 29, 2019 4:34 pm

Hi to all,

I have deleted the print directory on my DM42.

No problem, I thought, just re-create a 'PRINTS' new one at the root and it should be ok.

But no, nothing prints out : PRSTK, PRP and so on... yes, PON is activated and the printer icon activates when I print.

Any help or suggestions appreciated.

Thanks
Last edited by mezoganet on Tue Jan 29, 2019 6:38 pm, edited 1 time in total.
HP33E, HP34C, HP41C, HP16C, HP28S, HP42S, HP48S, HP12C, HP35S, DM42 and HP3000 @ work during 18 yrs as IT Mgr

Geoff Quickfall
Posts: 213
Joined: Wed May 24, 2017 8:44 pm
Location: Vancouver Canada
Contact:

Re: Printing issue

Post by Geoff Quickfall » Tue Jan 29, 2019 6:09 pm

The only thing I can think of is to save programs and reload the latest full update via usb.

Don’t save state as this will only save the corrupt print menu.

Geoff

mezoganet
Posts: 41
Joined: Tue Jan 22, 2019 12:54 pm
Location: Tours, France

Re: Printing issue

Post by mezoganet » Tue Jan 29, 2019 6:40 pm

Geoff Quickfall wrote:
Tue Jan 29, 2019 6:09 pm
The only thing I can think of is to save programs and reload the latest full update via usb.

Geoff
Geoff,

Thanks for your answer...

I can't find on SwissMIicros site a "full update" to load.

Patrick

EDIT...

Eveyrhing is ok, I just missed the « Print to file » configuration, nothing else. Restarting from an empty state after last update might be the origin.

Thanks Geoff
HP33E, HP34C, HP41C, HP16C, HP28S, HP42S, HP48S, HP12C, HP35S, DM42 and HP3000 @ work during 18 yrs as IT Mgr

Geoff Quickfall
Posts: 213
Joined: Wed May 24, 2017 8:44 pm
Location: Vancouver Canada
Contact:

Re: Printing issue

Post by Geoff Quickfall » Wed Jan 30, 2019 1:24 am

Good!

If you end up needing the latest firmware:

https://www.swissmicros.com/dm42/firmware/

Cheers

mezoganet
Posts: 41
Joined: Tue Jan 22, 2019 12:54 pm
Location: Tours, France

Re: Printing issue

Post by mezoganet » Wed Jan 30, 2019 6:11 am

Geoff Quickfall wrote:
Wed Jan 30, 2019 1:24 am
Good!

If you end up needing the latest firmware:

https://www.swissmicros.com/dm42/firmware/

Cheers
Geoff,

This is the firmware update that went well from the first release day.

It cannot help in anything else than update the firmware. It will not erase nor create the original directory structure nor modify your current settings/preferences.

So, something to know, if you erase some original directory (in my case 'PRINTS') just re-create it manually, but don't forget to setup 'PON' and 'Print to file' options.

Thanks again for your time.

Have a nice day !
HP33E, HP34C, HP41C, HP16C, HP28S, HP42S, HP48S, HP12C, HP35S, DM42 and HP3000 @ work during 18 yrs as IT Mgr

User avatar
akaTB
Posts: 275
Joined: Tue May 02, 2017 11:56 am

Re: Printing issue

Post by akaTB » Wed Jan 30, 2019 6:25 am

Maybe the content of https://www.swissmicros.com/dm42/fat/ should be updated.
Greetings,
    Massimo

-+×÷left is right and right is wrong :twisted:

rprosperi
Posts: 483
Joined: Mon Apr 24, 2017 5:48 pm
Location: New York

Re: Printing issue

Post by rprosperi » Wed Jan 30, 2019 1:40 pm

akaTB wrote:
Wed Jan 30, 2019 6:25 am
Maybe the content of https://www.swissmicros.com/dm42/fat/ should be updated.
There is a new HELP file in there, dated 190129, which you can manually copy to the DM42 /HELP folder, but I agree it would be nice to have a new version of FAT_YYMMDD.zip posted when something is updated, so it's easier to both notice that something is new and keep the content sets organized.
--bob p

DM42: β00071 & 00282

mezoganet
Posts: 41
Joined: Tue Jan 22, 2019 12:54 pm
Location: Tours, France

Re: Printing issue

Post by mezoganet » Wed Jan 30, 2019 2:23 pm

mezoganet wrote:
Tue Jan 29, 2019 6:40 pm

EDIT...

Eveyrhing is ok, I just missed the « Print to file » configuration, nothing else. Restarting from an empty state after last update might be the origin.

Thanks Geoff
@rprosperi

I did the last update as soon as issued...

The problem was the one above, in my edit.

Thanks anyway
HP33E, HP34C, HP41C, HP16C, HP28S, HP42S, HP48S, HP12C, HP35S, DM42 and HP3000 @ work during 18 yrs as IT Mgr

Post Reply