Updating from 3.3 to 3.10

Post here to share useful tips and tricks, to ask questions about using your DM42 or to report software-related problems
User avatar
TomC
Posts: 53
Joined: Mon Apr 24, 2017 7:00 pm
Location: Detroit/Palo Alto, USA/Third Stone

Re: Updating from 3.3 to 3.10

Post by TomC » Fri Oct 19, 2018 3:41 am

No, no exclamation marks appear in Control Panel.
I just re-installed the driver..

If I put the DM42 in bootloader mode, it shows up in the control panel as STM32 Bootloader.

If I put the DM42 in Activate USB mode, it shows up in the control panel as STM Mass Storage.

BUT in either case it never shows up in File manager!!!

I am able to work with the DM42 from another PC, but it would be nice to get this one working.

TomC
TomC
DM42:00068/03961

groenewe
Posts: 20
Joined: Sat Dec 02, 2017 10:49 am

Re: Updating from 3.3 to 3.10

Post by groenewe » Fri Oct 19, 2018 8:50 am

Are you 100% sure you followed the complete installation update as per https://www.swissmicros.com/dm42/doc/libusb_install/ instruction?

DA74254
Posts: 40
Joined: Tue Oct 03, 2017 9:20 pm
Location: Norway/Latvia

Re: Updating from 3.3 to 3.10

Post by DA74254 » Fri Oct 19, 2018 1:56 pm

groenewe wrote:
Fri Oct 19, 2018 8:50 am
Are you 100% sure you followed the complete installation update as per https://www.swissmicros.com/dm42/doc/libusb_install/ instruction?
If you don't need to access bootloader mode, only the mass storage mode, you do not need to have the libsub installed.
I have connected my 42 to several PC's and even Android systems without the libsub installed and it works perfectly as a mass storage device with access to the FAT/QSPI partition.
Esben
DM42 SN: 00245

User avatar
TomC
Posts: 53
Joined: Mon Apr 24, 2017 7:00 pm
Location: Detroit/Palo Alto, USA/Third Stone

Re: Updating from 3.3 to 3.10

Post by TomC » Sun Oct 21, 2018 12:05 am

This machine has had the driver installed since the ver 2.xx days (beta testing).

Upgrades always worked fine until this 3.10 business.

I've since re-installed the driver with the same results.

I only explained the bootloader vs USB activated modes to describe some of the PC weirdness.

The ROOT problem is the file manager on the PC does not 'see' the DM42 no matter what I do.

TomC
TomC
DM42:00068/03961

toml_12953
Posts: 447
Joined: Wed May 03, 2017 5:46 pm
Location: Malone, NY USA

Re: Updating from 3.3 to 3.10

Post by toml_12953 » Sun Oct 21, 2018 7:48 am

TomC wrote:
Sun Oct 21, 2018 12:05 am
The ROOT problem is the file manager on the PC does not 'see' the DM42 no matter what I do.
Are you using the same USB cable you've always used? If not, have you tried a different USB cable? Once I used the first USB cable I could find in my parts box and the PC couldn't see the calculator but the calculator showed it was charging. It turns out that the cable I grabbed was for charging only, not both charging and data. Yes there are two different cables that look the same but have different functions. If the cable is one you've used before, try using different USB ports on your computer.
Tom L

Ducator meus nihil agit sine lagunculae leynidae accedunt

DM42 SN: 00025 (Beta)
SN: 00221 (Shipping)

groenewe
Posts: 20
Joined: Sat Dec 02, 2017 10:49 am

Re: Updating from 3.3 to 3.10

Post by groenewe » Sun Oct 21, 2018 9:04 am

Indeed indeed. There are pure power USB cables which do nothing with the data. I had that twice. Trashed one of them now at the office. However you immediately notice that as when you plug in the right one Windows immediately recognizes it as a drive whilst with the power only cable it does not.

User avatar
Walter
Posts: 793
Joined: Tue May 02, 2017 9:13 am
Location: Close to FRA, Germany

Re: Updating from 3.3 to 3.10

Post by Walter » Sun Oct 21, 2018 10:47 am

groenewe wrote:
Sun Oct 21, 2018 9:04 am
Indeed indeed. There are pure power USB cables which do nothing with the data. I had that twice. Trashed one of them now at the office. However you immediately notice that as when you plug in the right one Windows immediately recognizes it as a drive whilst with the power only cable it does not.
+1
DM42 SN: 00041 --- Follower of Platon.

HP-35, HP-45, ..., HP-50, WP 34S, WP 31S, DM16L

DA74254
Posts: 40
Joined: Tue Oct 03, 2017 9:20 pm
Location: Norway/Latvia

Re: Updating from 3.3 to 3.10

Post by DA74254 » Sun Oct 21, 2018 1:47 pm

groenewe wrote:
Sun Oct 21, 2018 9:04 am
Indeed indeed. There are pure power USB cables which do nothing with the data. I had that twice. Trashed one of them now at the office. However you immediately notice that as when you plug in the right one Windows immediately recognizes it as a drive whilst with the power only cable it does not.
toml_12953 wrote:
Sun Oct 21, 2018 7:48 am
TomC wrote:
Sun Oct 21, 2018 12:05 am
The ROOT problem is the file manager on the PC does not 'see' the DM42 no matter what I do.
Are you using the same USB cable you've always used? If not, have you tried a different USB cable? Once I used the first USB cable I could find in my parts box and the PC couldn't see the calculator but the calculator showed it was charging. It turns out that the cable I grabbed was for charging only, not both charging and data. Yes there are two different cables that look the same but have different functions. If the cable is one you've used before, try using different USB ports on your computer.
As long as i obtains contact with the calc in Bootloader mode, he uses a fully connected usb cable. He has stated several times through this thread that his calc responds via Bootloader.
Esben
DM42 SN: 00245

DA74254
Posts: 40
Joined: Tue Oct 03, 2017 9:20 pm
Location: Norway/Latvia

Re: Updating from 3.3 to 3.10

Post by DA74254 » Sun Oct 21, 2018 7:22 pm

TomC;
Come to think of something..
When you switch off your calc, do you get the "user customisable" off-image or the "sleeping owl on the tree branch"?
If you get the last one, that means that your FAT/QSPI may be faulty and thus does not get recognised by the PC..
Esben
DM42 SN: 00245

groenewe
Posts: 20
Joined: Sat Dec 02, 2017 10:49 am

Re: Updating from 3.3 to 3.10

Post by groenewe » Mon Oct 22, 2018 9:21 am

I'm getting everytime another picture. MEaning the pictures are cycling through the normal list.

Post Reply