Updating from 3.3 to 3.10

Post here to share useful tips and tricks, to ask questions about using your DM42 or to report software-related problems
User avatar
ijabbott
Posts: 109
Joined: Fri Dec 15, 2017 1:34 pm
Location: Manchester, UK

Re: Updating from 3.3 to 3.10

Post by ijabbott » Mon Oct 22, 2018 5:01 pm

Perhaps Windows sees it as a FAT partition but with no drive letter assigned?

If you start diskmgmt.msc, does it appear as a small, removable drive (around 6 MB large)?

If so, is it shown as having a FAT partition?

If so, can you right click on it and use the "Change Drive Letter and Paths..." option to assign a drive letter if it has none?

User avatar
TomC
Posts: 53
Joined: Mon Apr 24, 2017 7:00 pm
Location: Detroit/Palo Alto, USA/Third Stone

Re: Updating from 3.3 to 3.10

Post by TomC » Sun Oct 28, 2018 4:57 pm

Thank you again to all of you for your attention... . ....
++++++++++++++++++++++++++++++++++++++++++++++++
So, just to review:

I've ruled out the cable and the physical connection to the PC.

I can do things on another PC, but I am most curious to get it working on this PC (which I had been using since my beta DM unit through about 2.12 or 3.2, I don't recall for certain).

I also now have another(new) DM42 and it acts the same way.

So, it is apparent to me something is wrong with the driver on this PC (even though I have re-installed it during this current issue. (although I did not de-install the old one).

So, both of these DM42s 'act' the same way - that is:
When USB is activated, the PC chirps, yet the DM does NOT show up in filemanager. The driver DOES show up in Control Panel when the DM is connected.

FWIW, my first DM is now 3.10, the 'new' one is 3.9.

I've been trying to figure out what has changed on this PC to cause the driver to 'suddenly' act up.

WELL, I was just reminded that I had used this PC to update a NUMWORKS calculator. WELL, it uses a 'similar'/looks like the same driver. The NUMWORKS machine also uses a STM32.

So, I will continue, I'm hoping that removing this driver from this PC and reinstalling it will clear things up; stay tuned!

TomC
DM42:0067/03961
DA74254 wrote:
Sun Oct 21, 2018 7:22 pm
TomC;
Come to think of something..
When you switch off your calc, do you get the "user customisable" off-image or the "sleeping owl on the tree branch"?
If you get the last one, that means that your FAT/QSPI may be faulty and thus does not get recognised by the PC..
TomC
DM42:00068/03961

User avatar
TomC
Posts: 53
Joined: Mon Apr 24, 2017 7:00 pm
Location: Detroit/Palo Alto, USA/Third Stone

Re: Updating from 3.3 to 3.10

Post by TomC » Sun Oct 28, 2018 5:09 pm

Good News Everyone!!!

I de-installed the driver and re-installed.

Although it reported 'Other error' at the end of the install, the DM now shows in File Manager!!!

Hallelujah!

TomC :D
67/3961
TomC
DM42:00068/03961

User avatar
Walter
Posts: 793
Joined: Tue May 02, 2017 9:13 am
Location: Close to FRA, Germany

Re: Updating from 3.3 to 3.10

Post by Walter » Sun Oct 28, 2018 5:15 pm

Congratulations!

So at the bottom line the problem was on the PC side, not on the DM side.
DM42 SN: 00041 --- Follower of Platon.

HP-35, HP-45, ..., HP-50, WP 34S, WP 31S, DM16L

grsbanks
Posts: 709
Joined: Tue Apr 25, 2017 9:23 am
Location: Preston, Lancs, UK

Re: Updating from 3.3 to 3.10

Post by grsbanks » Sun Oct 28, 2018 5:16 pm

You got there too fast.

In order to see the DM42 in the file manager you don't need any drivers at all. The DM42 behaves exactly like a memory stick and you don't need drivers for memory sticks, right? The drivers that you installed (libusb) are for dm_tool to "see" the DM42 in bootloader mode.
Not SwissMicros staff, just an enthusiast.

rprosperi
Posts: 375
Joined: Mon Apr 24, 2017 5:48 pm
Location: New York

Re: Updating from 3.3 to 3.10

Post by rprosperi » Sun Oct 28, 2018 5:56 pm

TomC wrote:
Sun Oct 28, 2018 5:09 pm
Good News Everyone!!!

I de-installed the driver and re-installed.

Although it reported 'Other error' at the end of the install, the DM now shows in File Manager!!!
Great, glad you got this resolved; seems like the numworks installation somehow hosed some of your windows drivers!?!?

And thanks for confirming the problem is NOT the DM42; often, folks will complain about an issue, and then when finally resolved, not take the time to set the record straight, possibly leaving a negative impression for others.
--bob p

DM42: β00071 & 00282

Post Reply