Page 1 of 3

Bug when connecting the USB cable

Posted: Fri Jun 15, 2018 1:31 pm
by StreakyCobra
Hi,

I just received my DM42 and its a really nice device. There is an issue with the USB cable though:

Image

Transcript (for making search easier in this forum, and for posterity if imgur closes):

Code: Select all

Err:Src/main.c:867
Err:main.c:867
Err:SetFreq 2
ERROR: 0777
Desc:SetFreq 2
This happens directly at the moment I plug the USB cable in the device, tested both on different computers (windows and linux) and with different USB cables. When this error appears, the calculator is then stuck. The only way out is to remove the USB cable and press the reset button on the back.

Here are a few notes:
  • This also happen when I do "Activate USB disk" before plugging the cable in.
  • If I put it in while on the "About" screen after reset, it doesn't throw an error directly, but after dismissing the screen get stuck on "Checking QSPI contents …"
  • I manage, sometimes, to make USB work with this procedure:
    1. Press the reset button and wait for the "About" screen to appear
    2. Prepare the USB cable close to the plug
    3. Dismiss the about screen by pressing "Exit" and quickly insert the USB cable
    4. Some other messages I got while trying to make it work:

      Code: Select all

      Oops, RESET in protected area.
      Please, report following info
      if the system had hung:
      Reg Id d3770001, fw 3.7
      

      Code: Select all

      Oops, I've crashed! Please, try
      to reproduce it, then report the
      steps taken and following info:
      
      Hard Fault
       r0=10005a0c  r1=00000040
       r2=00000000  r3=00000000
      r12=00000001  lr=ffffffed
       pc=00f00000 psr=00010029
      
  • Device:

    Code: Select all

    SN 00874
Thanks in advance for your help :)

Re: Bug when connecting the USB cable

Posted: Fri Jun 15, 2018 1:41 pm
by Michael
I'm afraid this is a hardware related issue.
Please contact me via email for an exchange.

Re: Bug when connecting the USB cable

Posted: Fri Jun 15, 2018 5:00 pm
by wawachief
This is strange, I have the exact same problem since this morning :
Image

It worked perfectly fine since I received my unit in december. Then, I made the upgrade to 3.7 firmware, and now, as soon as I plug the usb cable, the error appears and the calculator freezes. I have to press reset to reboot it. It works until I plug the USB cable again...

Please tell me it is not a hardware problem too :(

Re: Bug when connecting the USB cable - Back to life !

Posted: Fri Jun 15, 2018 8:22 pm
by wawachief
I managed to downgrade to 3.5 firmware by removing the back case and pressing PRGM+RESET to get into bootloader mode, then flashing the old firmware with dfu-util.

With the 3.5 firmware everything seems to be back to normal, I can access my FAT disk again so it seems not to be a hardware problem :)

I'm not sure if I can reupgrade to 3.7 now.... Is it really safe ?

Re: Bug when connecting the USB cable

Posted: Fri Jun 15, 2018 11:44 pm
by rprosperi
I just connected my DM42 running f/w Ver 3.71 to my PC via USB cable with no trouble; it worked as expected, files on Flash were visisble to the PC, etc. so the issue reported above is not present in all 3.7 f/w DM42 machines. I don't doubt that the 2 reports are real problems, I just wanted to verify and confirm that this problem is *NOT* present in all machines.

Re: Bug when connecting the USB cable

Posted: Sat Jun 16, 2018 1:49 am
by pcscote
rprosperi wrote:
Fri Jun 15, 2018 11:44 pm
I just connected my DM42 running f/w Ver 3.71 to my PC via USB cable with no trouble; it worked as expected, files on Flash were visisble to the PC, etc. so the issue reported above is not present in all 3.7 f/w DM42 machines. I don't doubt that the 2 reports are real problems, I just wanted to verify and confirm that this problem is *NOT* present in all machines.
Same here, tried multiple times, on different ports, on a MacBookPro running 10.13.5 without any error.

Re: Bug when connecting the USB cable

Posted: Sat Jun 16, 2018 6:49 am
by wawachief
I tried to upgrade to 3.7 again. I double checked the upgrade procedure, I downloaded the files again, compared the checksums, they were OK. I upgraded the DMCP then the program... and I am back into trouble, same error again when I plug the USB cable. So the problem is reproducible and has something to do with the 3.7 firmware.

... and yes, I tried different cables with different computers.

Re: Bug when connecting the USB cable

Posted: Sat Jun 16, 2018 7:05 am
by wawachief
The problem seems to come from the DMCP part because I compiled the Hello world program. It works but the calculator still crashes when I plug the USB cable
Image

Re: Bug when connecting the USB cable

Posted: Mon Jun 25, 2018 10:17 am
by Thomas_ER
bump
Any news from Swissmicros to this issue?

Re: Bug when connecting the USB cable

Posted: Mon Jun 25, 2018 10:26 am
by grsbanks
See this reply from Michael further up the thread:

viewtopic.php?p=8557#p8495