[DM41L V27] Turning off alarm bug

If you think you've found a bug in one of these machines, post about it here indicating the steps you perform in order to reproduce it.

Please prefix your topic with the model number in question and firmware version this way:

[DM16 V22] CHS gives unexpected results
Post Reply
michel_b
Posts: 26
Joined: Wed Jan 30, 2019 9:07 pm

[DM41L V27] Turning off alarm bug

Post by michel_b » Thu Feb 07, 2019 9:01 am

Hi there,

I've noticed the following on my DM41L with FW V27 :

When an alarm goes off :

- If the calculator is ON, pressing the [←] key cancels the alarm and removes it from the [CATALOG 5]

- On the other hand, if the calculator is OFF and the alarm powers it up, pressing the [←] key has no effect and doesn't cancel the alarm. It seems that the only way to stop it is to turn the machine OFF then ON again, but then it is not removed from the [CATALOG 5], and needs to be removed manually.

Although being a newcomer to the DM41L (and HP-41), it doesn't seem to me as being the expected behaviour ?

Kind regards.

grsbanks
Posts: 816
Joined: Tue Apr 25, 2017 9:23 am
Location: Preston, Lancs, UK
Contact:

Re: [DM41L V27] Turning off alarm bug

Post by grsbanks » Thu Feb 07, 2019 6:00 pm

I've been trying to nail down the precise circumstances in which this happens for a while now so that I can file an accurate bug report. Even if the calculator was off when the alarm became due, most of the time the [<--] key behaves as expected. Sometimes it doesn't!

Long story short, we know about it and we're looking to find a solution :)
Not SwissMicros staff, just an enthusiast.

michel_b
Posts: 26
Joined: Wed Jan 30, 2019 9:07 pm

Re: [DM41L V27] Turning off alarm bug

Post by michel_b » Thu Feb 07, 2019 8:30 pm

Here it's quite reproducible : on my device it did it just every time.

grsbanks
Posts: 816
Joined: Tue Apr 25, 2017 9:23 am
Location: Preston, Lancs, UK
Contact:

Re: [DM41L V27] Turning off alarm bug

Post by grsbanks » Wed Feb 20, 2019 6:39 pm

Quick update on this bug report...

We've isolated the problem and it's looking like we've got a working solution. michel_b is helping with the testing of this and once everyone is happy that it is fixed, it'll be part of firmware V28.
Not SwissMicros staff, just an enthusiast.

Post Reply